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This application note shows how the function SendReport(...) is used with
ViSi-Genie Magic objects. The function SendReport(...) is one of the callable
functions in the new ViSi-Genie Communications protocol. This function
causes the program to send a REPORT_EVENT or a REPORT_OBJ message to
the serial port. This function can be inserted into the code of a Genie Magic
object.

Note 1: The ViSi-Genie project for this application note is based on the demo
“SlideToUnlock”, which is found in Worskhop. Go to the File menu ->
Samples -> ViSi Genie Magic (Picaso/Diablo16) -> SlideToUnlock.4DGenie.

Note 2: Worskhop Pro is needed for this application.

This application note shows how the function SendReport(...) is used with
ViSi-Genie Magic objects. The function SendReport(...) is one of the callable
functions in the new ViSi-Genie Communications protocol. This function
causes the program to send a REPORT_EVENT or a REPORT_OBJ message to
the serial port. This function can be inserted into the code of a Genie Magic
object.

Note 1: The ViSi-Genie project for this application note is based on the demo
“SlideToUnlock”, which is found in Worskhop. Go to the File menu ->
Samples -> ViSi Genie Magic (Picaso/Diablo16) -> SlideToUnlock.4DGenie.

Note 2: Worskhop Pro is needed for this application.

Before getting started, the following are required:

e Any of the following 4D Picaso display modules:
gend-uLCD-24PT
gend-uLCD-28PT
gend-uLCD-32PT
uLCD-24PTU
uLCD-28PTU
uVGA-III

and other superseded modules which support the ViSi Genie environment

e The target module can also be a Diablo16 display
gend-ulLCD-24D series
gen4-ulLCD-28D series
gen4-ulLCD-32D series
gen4-uLCD-35D series
gen4-ulLCD-43D series
gen4-uLCD-50D series
gen4-ulLCD-70D series
uLCD-35DT
uLCD-43D Series
uLCD-70DT

Visit www.4dsystems.com.au/products to see the latest display

module products that use the Diablo16 processor.
e 4D Programming Cable or uUSB-PA5
e micro-SD (uSD) memory card

e Workshop 4 IDE (installed according to the installation document)

e When downloading an application note, a list of recommended
application notes is shown. It is assumed that the user has read or
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https://www.4dsystems.com.au/product/gen4_uLCD_24PT/
https://www.4dsystems.com.au/product/gen4_uLCD_28PT/
https://www.4dsystems.com.au/product/gen4_uLCD_32PT/
http://www.4dsystems.com.au/product/1/7/4D_Intelligent_Display_Modules/uLCD_24PTU/
http://www.4dsystems.com.au/product/1/8/4D_Intelligent_Display_Modules/uLCD_28PTU/
http://www.4dsystems.com.au/product/1/124/4D_Intelligent_Display_Modules/uVGA_III/
https://www.4dsystems.com.au/product/gen4_uLCD_24D/
https://www.4dsystems.com.au/product/gen4_uLCD_28D/
https://www.4dsystems.com.au/product/gen4_uLCD_32D/
https://www.4dsystems.com.au/product/gen4_uLCD_35D/
https://www.4dsystems.com.au/product/gen4_uLCD_43D/
https://www.4dsystems.com.au/product/gen4_uLCD_50D/
https://www.4dsystems.com.au/product/gen4_uLCD_70D/
https://www.4dsystems.com.au/product/uLCD_35DT/
https://www.4dsystems.com.au/product/uLCD_43D/
https://www.4dsystems.com.au/product/uLCD_70DT/
http://www.4dsystems.com.au/products
http://www.4dsystems.com.au/product/17/114/Accessories/4D-Programming-Cable/
http://www.4dsystems.com.au/product/17/115/Accessories/uUSB-PA5/
http://www.4dsystems.com.au/product/uSD_2GB/
http://www.4dsystems.com.au/product/10/120/Development/4D_Workshop_4_IDE/
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has a working knowledge of the topics presented in these
recommended application notes.
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Application Overview

To understand this application note more quickly, the reader is advised to
read and understand first the application note ViSi-Genie Magic Slide to
Unlock. ViSi-Genie Magic Slide to Unlock shows how a stand-alone ViSi-
Genie program with a slide-to-unlock feature is created. The slide-to-unlock

project has two forms. The first form has a slider whose knob, when dragged
to the right-most part, triggers the program to navigate to the second form.
A winbutton on the second form, when pressed, causes the program to
navigate back to the first form.

This application note shows how to modify the project in ViSi-Genie Magic
Slide to Unlock, such that when the knob of the slider is moved to the
extreme right (the program is unlocked), a message is sent to the serial port.
Also, when the winbutton on the second form is pressed (the program is
locked), another message is sent to the serial port.

Setup Procedure

For instructions on how to launch Workshop 4, how to open a ViSi-Genie
project, and how to change the target display, kindly refer to the section
“Setup Procedure” of the application note:

ViSi Genie Getting Started — First Project for Picaso Displays (for Picaso)

or
ViSi Genie Getting Started — First Project for Diablo16 Displays (for
Diablo16).
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http://www.4dsystems.com.au/appnote/4D-AN-00151/
http://www.4dsystems.com.au/appnote/4D-AN-00151/
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Design the Project

There are two ways of making the slide-to-unlock program report a message
when navigating between the two forms (unlock and lock). One way is to
use the OnChanged property event of a form. Another way is to use the
function SendReport(...) with the Magic Event object.

Add a SendReport(...) Fucntion to MagicEvent0

Insert the SendReport(...) function to MagicEventO as shown below.

= func MagicEs
(] r 18lider0, IMAGE INDEX)

ndReport (REPORT EVENT, tForm,

WriteObject (tGSlider

endfunc

This will cause the program to send a REPORT_EVENT message to the serial
port just after Form1 is activated. For more information about this function,
see section 5.1 Genie Magic callable Functions of the ViSi-Genie Reference

Manual.

Configure the OnActivate Event Property of FormO

Set the OnActivate Event property value of FormO as indicated below.

Object Inspector Bl
Form | Formo W

Object |FormO V«
Properties | Events

This will cause the program to send a REPORT_EVENT message to the serial

Event Handler

OnActivate Report Message

port every time that FormO is activated.

Build and Upload the Project

For instructions on how to build and upload a ViSi-Genie project to the

target display, please refer to the section “Build and Upload the Project” of
the application note

ViSi Genie Getting Started — First Project for Picaso Displays (for Picaso)

or
ViSi Genie Getting Started — First Project for Diablo16 Displays (for
Diablo16).

The uLCD-32PTU and/or the uLCD-35DT display modules are commonly
used as examples, but the procedure is the same for other displays.
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Identify the Messages

The display module is going to send messages to an external host. This
section explains to the user how to interpret these messages. An
understanding of this section is necessary for users who intend to interface
the display to a host. The ViSi Genie Reference Manual is recommended for

advanced users.

Use the GTX Tool to Analyse the Messages

Using the GTX or Genie Test eXecutor tool is one option to get the messages
sent by the display to the host. Here the PC will be the host. The GTX tool is
a part of the Workshop 4 IDE. It allows the user to receive, observe, and send
messages from and to the display module. It is an essential debugging tool.

Launch the GTX Tool
Under the Tools menu click on the GTX tool button.

Home View Tools | Comms  Project

[#1 Terminal 9600 @ E«
GTX

@ PmmC Loader I::] Terminal 115200 4DGL
uVGA Link

B Boot usD

% RMPet

The Genie Test eXecutor window appears.

o Genie Test eXecutor - 0O
Control
Port: COM 3 D Reset on open hﬁ Disconnect 7 : Contrast
Active Form
Query Form1
Sliders
Query
—
Set
WinButtons
Query
Buttond

Unlock the Program

On the display module, drag the knob of the slider to the right-most part
and release. The program should now navigate to Forml and a
REPORT_EVENT message should be received from the display.

Page 6 of 8

www.4dsystems.com.au


http://www.4dsystems.com.au/product/4D_Workshop_4_IDE/downloads

APPLICATION NOTES

4D-AN-00172

Contr
kdw 7 = | contrast 9600

Form Changese 16:27:47.411 [07 0& 01 00O OO OC]

The format of the message is shown below.

Object Object Value @ Value

Command Checksum

Type Index MSB LSB

0x07 0x0A | 0x01 | 0x00 | 0x00 0x0C

REPORT_EVENT ‘ Form ‘ Second ‘

Upon receiving the above message, the host would know that the display
has been “unlocked” and that Form1 or the second has been activated.

Lock the Program

Press the lock button on Form1. The program should now navigate to Form0O
and a REPORT_EVENT message should be received from the display.

Contr
on open ‘,ﬂ[jﬂmnect 7 | Contrast

Form Change 13:43:51 086 [07 D& 01 00 0O OC]
Form Change 13:43:53_366 [07 D& OO0 00 0O 0OD]

The format of the message is shown below.

Object Object Value Value

Command Checksum

Type Index MSB LSB

0x07 0x0A 0x00 0x00 | 0x00 0x0D

REPORT_EVENT’ Form ‘ First ‘

Upon receiving the above message, the host would know that the display
has been “locked” and that FormO or the first form has been activated.
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Proprietary Information

The information contained in this document is the property of 4D Systems Pty. Ltd. and may be the subject of patents pending or granted, and must not be

copied or disclosed without prior written permission.

4D Systems endeavours to ensure that the information in this document is correct and fairly stated but does not accept liability for any error or omission. The
development of 4D Systems products and services is continuous and published information may not be up to date. It is important to check the current position
with 4D Systems.

All trademarks belong to their respective owners and are recognised and acknowledged.

Disclaimer of Warranties & Limitation of Liability

4D Systems makes no warranty, either expresses or implied with respect to any product, and specifically disclaims all other warranties, including, without
limitation, warranties for merchantability, non-infringement and fitness for any particular purpose.

Information contained in this publication regarding device applications and the like is provided only for your convenience and may be superseded by updates.
It is your responsibility to ensure that your application meets with your specifications.

In no event shall 4D Systems be liable to the buyer or to any third party for any indirect, incidental, special, consequential, punitive or exemplary damages
(including without limitation lost profits, lost savings, or loss of business opportunity) arising out of or relating to any product or service provided or to be
provided by 4D Systems, or the use or inability to use the same, even if 4D Systems has been advised of the possibility of such damages.

4D Systems products are not fault tolerant nor designed, manufactured or intended for use or resale as on line control equipment in hazardous environments
requiring fail — safe performance, such as in the operation of nuclear facilities, aircraft navigation or communication systems, air traffic control, direct life
support machines or weapons systems in which the failure of the product could lead directly to death, personal injury or severe physical or environmental
damage (‘High Risk Activities’). 4D Systems and its suppliers specifically disclaim any expressed or implied warranty of fitness for High Risk Activities.

Use of 4D Systems’ products and devices in 'High Risk Activities' and in any other application is entirely at the buyer’s risk, and the buyer agrees to defend,
indemnify and hold harmless 4D Systems from any and all damages, claims, suits, or expenses resulting from such use. No licenses are conveyed, implicitly or
otherwise, under any 4D Systems intellectual property rights.
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